Vulnerability CVE-2018-1086


Published: 2018-04-12   Modified: 2018-04-15

Description:
pcs before versions 0.9.164 and 0.10 is vulnerable to a debug parameter removal bypass. REST interface of the pcsd service did not properly remove the pcs debug argument from the /run_pcs query, possibly disclosing sensitive information. A remote attacker with a valid token could use this flaw to elevate their privilege.

Type:

CWE-200

(Information Exposure)

CVSS2 => (AV:N/AC:L/Au:N/C:P/I:N/A:N)

CVSS Base Score
Impact Subscore
Exploitability Subscore
5/10
2.9/10
10/10
Exploit range
Attack complexity
Authentication
Remote
Low
No required
Confidentiality impact
Integrity impact
Availability impact
Partial
None
None
Affected software
Redhat -> Enterprise linux 
Redhat -> Enterprise linux server eus 
Debian -> Debian linux 
Clusterlabs -> Pacemaker command line interface 

 References:
https://access.redhat.com/errata/RHSA-2018:1060
https://access.redhat.com/errata/RHSA-2018:1927
https://bugzilla.redhat.com/show_bug.cgi?id=CVE-2018-1086
https://www.debian.org/security/2018/dsa-4169

Copyright 2022, cxsecurity.com

 

Back to Top