Vulnerability CVE-2018-10915


Published: 2018-08-09

Description:
A vulnerability was found in libpq, the default PostgreSQL client library where libpq failed to properly reset its internal state between connections. If an affected version of libpq was used with "host" or "hostaddr" connection parameters from untrusted input, attackers could bypass client-side connection security features, obtain access to higher privileged connections or potentially cause other impact through SQL injection, by causing the PQescape() functions to malfunction. Postgresql versions before 10.5, 9.6.10, 9.5.14, 9.4.19, and 9.3.24 are affected.

 References:
https://bugzilla.redhat.com/show_bug.cgi?id=CVE-2018-10915
https://www.postgresql.org/about/news/1878/

Copyright 2018, cxsecurity.com

 

Back to Top