Vulnerability CVE-2018-11688


Published: 2018-06-13

Description:
Ignite Realtime Openfire before 3.9.2 is vulnerable to cross-site scripting, caused by improper validation of user-supplied input. A remote attacker could exploit this vulnerability via a crafted URL to execute script in a victim's Web browser within the security context of the hosting Web site, once the URL is clicked. An attacker could use this vulnerability to steal the victim's cookie-based authentication credentials.

See advisories in our WLB2 database:
Topic
Author
Date
Low
Ignite Realtime Openfire 3.7.1 Cross Site Scripting
Yavuz Atlas
06.06.2018

Type:

CWE-79

(Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting'))

CVSS2 => (AV:N/AC:M/Au:N/C:N/I:P/A:N)

CVSS Base Score
Impact Subscore
Exploitability Subscore
4.3/10
2.9/10
8.6/10
Exploit range
Attack complexity
Authentication
Remote
Medium
No required
Confidentiality impact
Integrity impact
Availability impact
None
Partial
None
Affected software
Igniterealtime -> Igniterealtime 
Igniterealtime -> Openfire 

 References:
http://packetstormsecurity.com/files/148057/Ignite-Realtime-Openfire-3.7.1-Cross-Site-Scripting.html
http://seclists.org/fulldisclosure/2018/Jun/13
http://seclists.org/fulldisclosure/2018/Jun/24
http://www.securityfocus.com/archive/1/542060/100/0/threaded
https://github.com/igniterealtime/Openfire/commit/ed3492a24274fd454afe93a499db49f3d6335108#diff-3f607cf668ad8f1091e789a2c1dca32a
https://github.com/igniterealtime/Openfire/compare/v3.9.1...v3.9.2
https://vulmon.com/vulnerabilitydetails?qid=CVE-2018-11688

Copyright 2020, cxsecurity.com

 

Back to Top