Vulnerability CVE-2018-12426


Published: 2018-07-02

Description:
The WP Live Chat Support Pro plugin before 8.0.07 for WordPress is vulnerable to unauthenticated Remote Code Execution due to client-side validation of allowed file types, as demonstrated by a v1/remote_upload request with a .php filename and the image/jpeg content type.

Type:

CWE-434

(Unrestricted Upload of File with Dangerous Type)

Vendor: Wp-livechat
Product: Live chat support 
Version:
8.0.06
8.0.05
8.0.04
8.0.03
8.0.02
8.0.01
8.0.00
7.1.08
7.1.07
7.1.05
7.1.03
7.1.02
7.1.01
7.0.08
7.0.07
7.0.06
7.0.05
7.0.04
7.0.03
7.0.02
7.0.01
7.0.00
6.2.11
6.2.10
6.2.09
6.2.08
6.2.07
6.2.06
6.2.05
6.2.04
6.2.03
6.2.02
6.2.01
6.2.00
6.1.02
6.1.01
6.1.00
6.0.07
6.0.06
6.0.05
6.0.04
6.0.03
6.0.02
6.0.01
6.0.00
5.0.9
5.0.8
5.0.7
5.0.6
5.0.5
5.0.4
5.0.3
5.0.2
5.0.14
5.0.13
5.0.12
5.0.11
5.0.10
5.0.1
5.0.0
4.4.4
4.4.3
4.4.2
4.4.1
4.4.0
4.3.5
4.3.4
4.3.3
4.3.2
4.3.1
4.3.0
4.2.9
4.2.8
4.2.7
4.2.6
4.2.5
4.2.4
4.2.3
4.2.2
4.2.12
4.2.11
4.2.10
4.2.1
4.2.0
4.1.9
4.1.8
4.1.7
4.1.6
4.1.5
4.1.4
4.1.3
4.1.2
4.1.10
4.1.1
4.1.0
4.0.2
4.0.1
4.0.0
3.08
3.07
See more versions on NVD

CVSS2 => (AV:N/AC:L/Au:N/C:P/I:P/A:P)

CVSS Base Score
Impact Subscore
Exploitability Subscore
7.5/10
6.4/10
10/10
Exploit range
Attack complexity
Authentication
Remote
Low
No required
Confidentiality impact
Integrity impact
Availability impact
Partial
Partial
Partial

 References:
https://github.com/CodeCabin/wp-live-chat-support/blob/master/readme.txt
https://github.com/RiieCco/write-ups/tree/master/CVE-2018-12426
https://wpvulndb.com/vulnerabilities/9697

Related CVE
CVE-2014-10386
The wp-live-chat-support plugin before 4.1.0 for WordPress has JavaScript injections.
CVE-2017-18507
The wp-live-chat-support plugin before 7.1.05 for WordPress has XSS.
CVE-2019-14950
The wp-live-chat-support plugin before 8.0.27 for WordPress has XSS via the GDPR page.
CVE-2017-18508
The wp-live-chat-support plugin before 7.1.03 for WordPress has XSS.
CVE-2016-10879
The wp-live-chat-support plugin before 6.2.02 for WordPress has XSS.
CVE-2018-18460
XSS exists in the wp-live-chat-support v8.0.15 plugin for WordPress via the modules/gdpr.php term parameter in a wp-admin/admin.php wplivechat-menu-gdpr-page request.

Copyright 2019, cxsecurity.com

 

Back to Top