Vulnerability CVE-2018-18460


Published: 2018-10-18

Description:
XSS exists in the wp-live-chat-support v8.0.15 plugin for WordPress via the modules/gdpr.php term parameter in a wp-admin/admin.php wplivechat-menu-gdpr-page request.

Type:

CWE-79

(Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting'))

Vendor: Wp-livechat
Product: Wp live chat support 
Version: 8.0.15;

CVSS2 => (AV:N/AC:M/Au:N/C:N/I:P/A:N)

CVSS Base Score
Impact Subscore
Exploitability Subscore
4.3/10
2.9/10
8.6/10
Exploit range
Attack complexity
Authentication
Remote
Medium
No required
Confidentiality impact
Integrity impact
Availability impact
None
Partial
None

 References:
https://github.com/rakjong/vuln/blob/master/wordpress_wp-live-chat-support_XSS.pdf
https://wordpress.org/plugins/wp-live-chat-support/#developers

Related CVE
CVE-2014-10386
The wp-live-chat-support plugin before 4.1.0 for WordPress has JavaScript injections.
CVE-2017-18507
The wp-live-chat-support plugin before 7.1.05 for WordPress has XSS.
CVE-2019-14950
The wp-live-chat-support plugin before 8.0.27 for WordPress has XSS via the GDPR page.
CVE-2017-18508
The wp-live-chat-support plugin before 7.1.03 for WordPress has XSS.
CVE-2016-10879
The wp-live-chat-support plugin before 6.2.02 for WordPress has XSS.
CVE-2018-12426
The WP Live Chat Support Pro plugin before 8.0.07 for WordPress is vulnerable to unauthenticated Remote Code Execution due to client-side validation of allowed file types, as demonstrated by a v1/remote_upload request with a .php filename and the ima...

Copyright 2019, cxsecurity.com

 

Back to Top