Vulnerability CVE-2018-18584


Published: 2018-10-22   Modified: 2018-10-23

Description:
In mspack/cab.h in libmspack before 0.8alpha and cabextract before 1.8, the CAB block input buffer is one byte too small for the maximal Quantum block, leading to an out-of-bounds write.

Type:

CWE-787

Vendor: Debian
Product: Debian linux 
Version: 8.0;
Vendor: Redhat
Product: Enterprise linux 
Version: 7.0;
Vendor: Canonical
Product: Ubuntu linux 
Version:
18.10
18.04
16.04
14.04
12.04
Vendor: SUSE
Product: Linux enterprise server 
Version: 12; 11;
Vendor: Kyzer
Product: Limbspack 
Version:
0.8
0.7.1
0.7
0.6
0.5
0.4
0.3

CVSS2 => (AV:N/AC:M/Au:N/C:N/I:N/A:P)

CVSS Base Score
Impact Subscore
Exploitability Subscore
4.3/10
2.9/10
8.6/10
Exploit range
Attack complexity
Authentication
Remote
Medium
No required
Confidentiality impact
Integrity impact
Availability impact
None
None
Partial

 References:
https://access.redhat.com/security/cve/cve-2018-18584
https://bugs.debian.org/911640
https://github.com/kyz/libmspack/commit/40ef1b4093d77ad3a5cfcee1f5cb6108b3a3bcc2
https://lists.debian.org/debian-lts-announce/2018/10/msg00017.html
https://packetstormsecurity.com/files/150310/Ubuntu-Security-Notice-USN-3814-3.html
https://security.gentoo.org/glsa/201903-20
https://usn.ubuntu.com/3814-1/
https://usn.ubuntu.com/3814-2/
https://usn.ubuntu.com/3814-3/
https://www.cabextract.org.uk/#changes
https://www.openwall.com/lists/oss-security/2018/10/22/1
https://www.suse.com/security/cve/CVE-2018-18584/

Copyright 2019, cxsecurity.com

 

Back to Top