Vulnerability CVE-2018-20570


Published: 2018-12-28

Description:
jp2_encode in jp2/jp2_enc.c in JasPer 2.0.14 has a heap-based buffer over-read.

Type:

CWE-125

(Out-of-bounds Read)

CVSS2 => (AV:N/AC:M/Au:N/C:N/I:N/A:P)

CVSS Base Score
Impact Subscore
Exploitability Subscore
4.3/10
2.9/10
8.6/10
Exploit range
Attack complexity
Authentication
Remote
Medium
No required
Confidentiality impact
Integrity impact
Availability impact
None
None
Partial
Affected software
Jasper project -> Jasper 
Debian -> Debian linux 

 References:
https://github.com/mdadams/jasper/issues/191
https://lists.debian.org/debian-lts-announce/2019/01/msg00003.html

Copyright 2020, cxsecurity.com

 

Back to Top