Vulnerability CVE-2018-4386


Published: 2019-04-03

Description:
Multiple memory corruption issues were addressed with improved memory handling. This issue affected versions prior to iOS 12.1, tvOS 12.1, watchOS 5.1, Safari 12.0.1, iTunes 12.9.1, iCloud for Windows 7.8.

See advisories in our WLB2 database:
Topic
Author
Date
Med.
WebKit JSC ForInContext Invalidation
Google Security ...
03.12.2018
High
Sony Playstation 4 (PS4) < 6.72 WebKit Code Execution (PoC)
TJ
09.01.2020

Type:

CWE-119

(Improper Restriction of Operations within the Bounds of a Memory Buffer)

CVSS2 => (AV:N/AC:M/Au:N/C:P/I:P/A:P)

CVSS Base Score
Impact Subscore
Exploitability Subscore
6.8/10
6.4/10
8.6/10
Exploit range
Attack complexity
Authentication
Remote
Medium
No required
Confidentiality impact
Integrity impact
Availability impact
Partial
Partial
Partial
Affected software
Apple -> Icloud 
Apple -> Itunes 
Apple -> Safari 
Apple -> Iphone os 
Apple -> TVOS 
Apple -> Watchos 

 References:
https://support.apple.com/kb/HT209192
https://support.apple.com/kb/HT209194
https://support.apple.com/kb/HT209195
https://support.apple.com/kb/HT209196
https://support.apple.com/kb/HT209197
https://support.apple.com/kb/HT209198

Copyright 2020, cxsecurity.com

 

Back to Top