Vulnerability CVE-2018-5776


Published: 2018-01-18

Description:
WordPress before 4.9.2 has XSS in the Flash fallback files in MediaElement (under wp-includes/js/mediaelement).

Type:

CWE-79

(Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting'))

Vendor: Wordpress
Product: Wordpress 
Version:
4.8.1
4.8
4.7.5
4.7.3
4.7.2
4.7.1
4.7
4.5.5
4.5.3
4.5.2
4.5.1
4.4.4
4.4.2
4.4.1
4.4.0
4.3.0
4.2.3
4.2.2
4.2.1
4.2
4.1.1
4.1
4.0.1
4.0
3.9.3
3.9.2
3.9.1
3.9.0
3.9
3.8.4
3.8.3
3.8.2
3.8.1
3.8
3.7.5
3.7.4
3.7.1
3.7
3.6.1
3.6
3.5.1
3.5.0
3.4.2
3.4.1
3.4.0
3.3.3
3.3.2
3.3.1
3.3
3.2.1
3.2
3.1.4
3.1.3
3.1.2
3.1.1
3.1
3.0.6
3.0.5
3.0.4
3.0.3
3.0.2
3.0.1
3.0
2.9.2
2.9.1.1
2.9.1
2.9
2.8.6
2.8.5.2
2.8.5.1
2.8.5
2.8.4
2.8.3
2.8.2
2.8.1
2.8
2.7.1
2.7
2.6.5
2.6.3
2.6.2
2.6.1
2.6
2.5.1
2.5
2.3.3
2.3.2
2.3.1
2.3
2.2.3
2.2.2
2.2.1
2.2
2.1.3
2.1.2
2.1.1
2.1
2.0.9
2.0.8
2.0.7
See more versions on NVD

CVSS2 => (AV:N/AC:M/Au:N/C:N/I:P/A:N)

CVSS Base Score
Impact Subscore
Exploitability Subscore
4.3/10
2.9/10
8.6/10
Exploit range
Attack complexity
Authentication
Remote
Medium
No required
Confidentiality impact
Integrity impact
Availability impact
None
Partial
None

 References:
https://codex.wordpress.org/Version_4.9.2
https://github.com/WordPress/WordPress/commit/3fe9cb61ee71fcfadb5e002399296fcc1198d850
https://wordpress.org/news/2018/01/wordpress-4-9-2-security-and-maintenance-release/
https://wpvulndb.com/vulnerabilities/9006

Related CVE
CVE-2017-17093
wp-includes/general-template.php in WordPress before 4.9.1 does not properly restrict the lang attribute of an HTML element, which might allow attackers to conduct XSS attacks via the language setting of a site.
CVE-2017-17094
wp-includes/feed.php in WordPress before 4.9.1 does not properly restrict enclosures in RSS and Atom fields, which might allow attackers to conduct XSS attacks via a crafted URL.
CVE-2017-17091
wp-admin/user-new.php in WordPress before 4.9.1 sets the newbloguser key to a string that can be directly derived from the user ID, which allows remote attackers to bypass intended access restrictions by entering this string.
CVE-2017-17092
wp-includes/functions.php in WordPress before 4.9.1 does not require the unfiltered_html capability for upload of .js files, which might allow remote attackers to conduct XSS attacks via a crafted file.
CVE-2017-16510
WordPress before 4.8.3 is affected by an issue where $wpdb->prepare() can create unexpected and unsafe queries leading to potential SQL injection (SQLi) in plugins and themes, as demonstrated by a "double prepare" approach, a different vulnerability ...
CVE-2012-6707
WordPress through 4.8.2 uses a weak MD5-based password hashing algorithm, which makes it easier for attackers to determine cleartext values by leveraging access to the hash values. NOTE: the approach to changing this may not be fully compatible with ...
CVE-2016-9263
WordPress through 4.8.2, when domain-based flashmediaelement.swf sandboxing is not used, allows remote attackers to conduct cross-domain Flash injection (XSF) attacks by leveraging code contained within the wp-includes/js/mediaelement/flashmediaeleme...
CVE-2017-14990
WordPress 4.8.2 stores cleartext wp_signups.activation_key values (but stores the analogous wp_users.user_activation_key values as hashes), which might make it easier for remote attackers to hijack unactivated user accounts by leveraging database rea...

Copyright 2018, cxsecurity.com

 

Back to Top