Vulnerability CVE-2018-6519


Published: 2018-02-01   Modified: 2018-02-02

Description:
The SAML2 library before 1.10.4, 2.x before 2.3.5, and 3.x before 3.1.1 in SimpleSAMLphp has a Regular Expression Denial of Service vulnerability for fraction-of-seconds data in a timestamp.

Type:

CWE-74

CVSS2 => (AV:N/AC:L/Au:N/C:N/I:N/A:P)

CVSS Base Score
Impact Subscore
Exploitability Subscore
5/10
2.9/10
10/10
Exploit range
Attack complexity
Authentication
Remote
Low
No required
Confidentiality impact
Integrity impact
Availability impact
None
None
Partial
Affected software
Simplesamlphp -> Saml2 
Debian -> Debian linux 

 References:
https://simplesamlphp.org/security/201801-01
https://www.debian.org/security/2018/dsa-4127

Copyright 2022, cxsecurity.com

 

Back to Top