Vulnerability CVE-2018-6797


Published: 2018-04-17

Description:
An issue was discovered in Perl 5.18 through 5.26. A crafted regular expression can cause a heap-based buffer overflow, with control over the bytes written.

Type:

CWE-119

(Improper Restriction of Operations within the Bounds of a Memory Buffer)

Vendor: Debian
Product: Debian linux 
Version:
9.0
8.0
7.0
Vendor: Redhat
Product: Enterprise linux server 
Version:
7.6
7.5
7.4
7.3
7.0
Product: Enterprise linux workstation 
Version: 7.0; 6.0;
Vendor: PERL
Product: PERL 
Version:
5.25.9
5.25.8
5.25.7
5.25.6
5.25.5
5.25.4
5.25.3
5.25.2
5.25.12
5.25.11
5.25.10
5.25.1
5.25.0
5.24.4
5.24.3
5.24.2
5.24.1
5.24.0
5.23.9
5.23.8
5.23.7
5.23.6
5.23.5
5.23.4
5.23.3
5.23.2
5.23.1
5.23.0
5.22.4
5.22.3
5.22.2
5.22.1
5.22.0
5.22
5.21.9
5.21.8
5.21.7
5.21.6
5.21.5
5.21.4
5.21.3
5.21.2
5.21.11
5.21.10
5.21.1
5.21.0
5.20.3
5.20.2
5.20.1
5.20.0
5.18.4
Vendor: Canonical
Product: Ubuntu linux 
Version:
17.10
16.04
14.04

CVSS2 => (AV:N/AC:L/Au:N/C:P/I:P/A:P)

CVSS Base Score
Impact Subscore
Exploitability Subscore
7.5/10
6.4/10
10/10
Exploit range
Attack complexity
Authentication
Remote
Low
No required
Confidentiality impact
Integrity impact
Availability impact
Partial
Partial
Partial

 References:
http://www.securitytracker.com/id/1040681
http://www.securitytracker.com/id/1042004
https://access.redhat.com/errata/RHSA-2018:1192
https://rt.perl.org/Public/Bug/Display.html?id=132227
https://security.gentoo.org/glsa/201909-01
https://usn.ubuntu.com/3625-1/
https://www.debian.org/security/2018/dsa-4172

Related CVE
CVE-2019-17134
Amphora Images in OpenStack Octavia >=0.10.0 <2.1.2, >=3.0.0 <3.2.0, >=4.0.0 <4.1.0 allows anyone with access to the management network to bypass client-certificate based authentication and retrieve information or issue configuration commands via sim...
CVE-2019-17266
libsoup from versions 2.65.1 until 2.68.1 have a heap-based buffer over-read because soup_ntlm_parse_challenge() in soup-auth-ntlm.c does not properly check an NTLM message's length before proceeding with a memcpy.
CVE-2019-16866
Unbound before 1.9.4 accesses uninitialized memory, which allows remote attackers to trigger a crash via a crafted NOTIFY query. The source IP address of the query must match an access-control rule.
CVE-2019-16928
Exim 4.92 through 4.92.2 allows remote code execution, a different vulnerability than CVE-2019-15846. There is a heap-based buffer overflow in string_vformat in string.c involving a long EHLO command.
CVE-2019-14835
A buffer overflow flaw was found, in versions from 2.6.34 to 5.2.x, in the way Linux kernel's vhost functionality that translates virtqueue buffers to IOVs, logged the buffer descriptors during migration. A privileged guest user able to pass descript...
CVE-2019-10197
A flaw was found in samba versions 4.9.x up to 4.9.13, samba 4.10.x up to 4.10.8 and samba 4.11.x up to 4.11.0rc3, when certain parameters were set in the samba configuration file. An unauthenticated attacker could use this flaw to escape the shared ...
CVE-2019-15717
Irssi 1.2.x before 1.2.2 has a use-after-free if the IRC server sends a double CAP.
CVE-2019-11476
An integer overflow in whoopsie before versions 0.2.52.5ubuntu0.1, 0.2.62ubuntu0.1, 0.2.64ubuntu0.1, 0.2.66, results in an out-of-bounds write to a heap allocated buffer when processing large crash dumps. This results in a crash or possible code-exec...

Copyright 2019, cxsecurity.com

 

Back to Top