Vulnerability CVE-2019-11009


Published: 2019-04-08

Description:
In GraphicsMagick 1.4 snapshot-20190322 Q8, there is a heap-based buffer over-read in the function ReadXWDImage of coders/xwd.c, which allows attackers to cause a denial of service or information disclosure via a crafted image file.

Type:

CWE-125

(Out-of-bounds Read)

CVSS2 => (AV:N/AC:M/Au:N/C:P/I:N/A:P)

CVSS Base Score
Impact Subscore
Exploitability Subscore
5.8/10
4.9/10
8.6/10
Exploit range
Attack complexity
Authentication
Remote
Medium
No required
Confidentiality impact
Integrity impact
Availability impact
Partial
None
Partial
Affected software
Opensuse -> LEAP 
Graphicsmagick -> Graphicsmagick 
Debian -> Debian linux 

 References:
http://hg.graphicsmagick.org/hg/GraphicsMagick/rev/7cff2b1792de
http://lists.opensuse.org/opensuse-security-announce/2019-04/msg00093.html
http://lists.opensuse.org/opensuse-security-announce/2019-04/msg00107.html
http://lists.opensuse.org/opensuse-security-announce/2019-05/msg00006.html
http://lists.opensuse.org/opensuse-security-announce/2019-05/msg00020.html
http://lists.opensuse.org/opensuse-security-announce/2019-05/msg00021.html
http://lists.opensuse.org/opensuse-security-announce/2019-05/msg00055.html
https://lists.debian.org/debian-lts-announce/2019/04/msg00015.html
https://sourceforge.net/p/graphicsmagick/bugs/597/

Copyright 2020, cxsecurity.com

 

Back to Top