Vulnerability CVE-2019-11010


Published: 2019-04-08

Description:
In GraphicsMagick 1.4 snapshot-20190322 Q8, there is a memory leak in the function ReadMPCImage of coders/mpc.c, which allows attackers to cause a denial of service via a crafted image file.

Type:

CWE-399

(Resource Management Errors)

CVSS2 => (AV:N/AC:M/Au:N/C:N/I:N/A:P)

CVSS Base Score
Impact Subscore
Exploitability Subscore
4.3/10
2.9/10
8.6/10
Exploit range
Attack complexity
Authentication
Remote
Medium
No required
Confidentiality impact
Integrity impact
Availability impact
None
None
Partial
Affected software
Opensuse -> LEAP 
Graphicsmagick -> Graphicsmagick 
Debian -> Debian linux 

 References:
http://hg.graphicsmagick.org/hg/GraphicsMagick/rev/a348d9661019
http://lists.opensuse.org/opensuse-security-announce/2019-04/msg00093.html
http://lists.opensuse.org/opensuse-security-announce/2019-04/msg00107.html
https://lists.debian.org/debian-lts-announce/2019/04/msg00015.html
https://sourceforge.net/p/graphicsmagick/bugs/601/

Copyright 2020, cxsecurity.com

 

Back to Top