Vulnerability CVE-2019-11034


Published: 2019-04-18

Description:
When processing certain files, PHP EXIF extension in versions 7.1.x below 7.1.28, 7.2.x below 7.2.17 and 7.3.x below 7.3.4 can be caused to read past allocated buffer in exif_process_IFD_TAG function. This may lead to information disclosure or crash.

Type:

CWE-119

(Improper Restriction of Operations within the Bounds of a Memory Buffer)

CVSS2 => (AV:N/AC:L/Au:N/C:P/I:N/A:P)

CVSS Base Score
Impact Subscore
Exploitability Subscore
6.4/10
4.9/10
10/10
Exploit range
Attack complexity
Authentication
Remote
Low
No required
Confidentiality impact
Integrity impact
Availability impact
Partial
None
Partial
Affected software
PHP -> PHP 
Netapp -> Storage automation store 
Canonical -> Ubuntu linux 

 References:
http://lists.opensuse.org/opensuse-security-announce/2019-06/msg00010.html
http://lists.opensuse.org/opensuse-security-announce/2019-06/msg00012.html
https://bugs.php.net/bug.php?id=77753
https://lists.debian.org/debian-lts-announce/2019/05/msg00035.html
https://security.netapp.com/advisory/ntap-20190502-0001/
https://support.f5.com/csp/article/K44590877
https://usn.ubuntu.com/3953-1/
https://usn.ubuntu.com/3953-2/

Copyright 2020, cxsecurity.com

 

Back to Top