Vulnerability CVE-2019-11581


Published: 2019-08-09

Description:
There was a server-side template injection vulnerability in Jira Server and Data Center, in the ContactAdministrators and the SendBulkMail actions. An attacker is able to remotely execute code on systems that run a vulnerable version of Jira Server or Data Center. All versions of Jira Server and Data Center from 4.4.0 before 7.6.14, from 7.7.0 before 7.13.5, from 8.0.0 before 8.0.3, from 8.1.0 before 8.1.2, and from 8.2.0 before 8.2.3 are affected by this vulnerability.

Type:

CWE-94

(Improper Control of Generation of Code ('Code Injection'))

Vendor: Atlassian
Product: JIRA 
Version:
8.2.2
8.2.1
8.2.0
8.1.1
8.1.0
8.0.2
8.0.1
8.0.0
7.9.2
7.9.1
7.9.0
7.8.4
7.8.3
7.8.2
7.8.1
7.8.0
7.7.4
7.7.3
7.7.2
7.7.1
7.7.0
7.6.9
7.6.8
7.6.7
7.6.6
7.6.5
7.6.4
7.6.3
7.6.2
7.6.13
7.6.12
7.6.11
7.6.10
7.6.1
7.6.0
7.5.4
7.5.3
7.5.2
7.5.1
7.5.0
7.4.6
7.4.5
7.4.4
7.4.3
7.4.2
7.4.1
7.4.0
7.3.9
7.3.8
7.3.7
7.3.6
7.3.5
7.3.4
7.3.3
7.3.2
7.3.1
7.3.0
7.2.9
7.2.8
7.2.7
7.2.6
7.2.5
7.2.4
7.2.3
7.2.2
7.2.15
7.2.14
7.2.13
7.2.12
7.2.11
7.2.10
7.2.1
7.2.0
7.13.4
7.13.3
7.13.2
7.13.1
7.13.0
7.12.3
7.12.2
7.12.1
7.12.0
7.11.3
7.11.2
7.11.1
7.11.0
7.10.2
7.10.1
7.10.0
7.1.9
7.1.8
7.1.7
7.1.6
7.1.4
7.1.2
7.1.10
7.1.1
7.1.0
7.0.9
7.0.5
See more versions on NVD

CVSS2 => (AV:N/AC:M/Au:N/C:C/I:C/A:C)

CVSS Base Score
Impact Subscore
Exploitability Subscore
9.3/10
10/10
8.6/10
Exploit range
Attack complexity
Authentication
Remote
Medium
No required
Confidentiality impact
Integrity impact
Availability impact
Complete
Complete
Complete

 References:
https://jira.atlassian.com/browse/JRASERVER-69532

Related CVE
CVE-2019-8451
The /plugins/servlet/gadgets/makeRequest resource in Jira before version 8.4.0 allows remote attackers to access the content of internal network resources via a Server Side Request Forgery (SSRF) vulnerability due to a logic bug in the JiraWhitelist ...
CVE-2019-8450
Various templates of the Optimization plugin in Jira before version 7.13.6, and from version 8.0.0 before version 8.4.0 allow remote attackers who have permission to manage custom fields to inject arbitrary HTML or JavaScript via a cross site scripti...
CVE-2019-8449
The /rest/api/latest/groupuserpicker resource in Jira before version 8.4.0 allows remote attackers to enumerate usernames via an information disclosure vulnerability.
CVE-2019-14998
The Webwork action Cross-Site Request Forgery (CSRF) protection implementation in Jira before version 8.4.0 allows remote attackers to bypass its protection via "cookie tossing" a CSRF cookie from a subdomain of a Jira instance.
CVE-2019-14997
The AccessLogFilter class in Jira before version 8.4.0 allows remote anonymous attackers to learn details about other users, including their username, via an information expose through caching vulnerability when Jira is configured with a reverse Prox...
CVE-2019-14996
The FilterPickerPopup.jspa resource in Jira before version 7.13.7, and from version 8.0.0 before version 8.3.3 allows remote attackers to inject arbitrary HTML or JavaScript via a cross site scripting (XSS) vulnerability in the searchOwnerUserName pa...
CVE-2019-14995
The /rest/api/1.0/render resource in Jira before version 8.4.0 allows remote anonymous attackers to determine if an attachment with a specific name exists and if an issue key is valid via a missing permissions check.
CVE-2019-3394
There was a local file disclosure vulnerability in Confluence Server and Confluence Data Center via page exporting. An attacker with permission to editing a page is able to exploit this issue to read arbitrary file on the server under <install-direct...

Copyright 2019, cxsecurity.com

 

Back to Top