Vulnerability CVE-2019-12101


Published: 2019-05-15

Description:
coap_decode_option in coap.c in LibNyoci 0.07.00rc1 mishandles certain packets with "Uri-Path: (null)" and consequently allows remote attackers to cause a denial of service (segmentation fault).

Type:

CWE-476

(NULL Pointer Dereference)

Vendor: Libnyoci project
Product: Libnyoci 
Version: 0.07.00;

CVSS2 => (AV:N/AC:L/Au:N/C:N/I:N/A:P)

CVSS Base Score
Impact Subscore
Exploitability Subscore
5/10
2.9/10
10/10
Exploit range
Attack complexity
Authentication
Remote
Low
No required
Confidentiality impact
Integrity impact
Availability impact
None
None
Partial

 References:
https://github.com/darconeous/libnyoci/issues/21

Copyright 2019, cxsecurity.com

 

Back to Top