Vulnerability CVE-2019-13106


Published: 2019-08-06

Description:
Das U-Boot versions 2016.09 through 2019.07-rc4 can memset() too much data while reading a crafted ext4 filesystem, which results in a stack buffer overflow and likely code execution.

Type:

CWE-787

CVSS2 => (AV:N/AC:M/Au:N/C:P/I:P/A:C)

CVSS Base Score
Impact Subscore
Exploitability Subscore
8.3/10
8.5/10
8.6/10
Exploit range
Attack complexity
Authentication
Remote
Medium
No required
Confidentiality impact
Integrity impact
Availability impact
Partial
Partial
Complete
Affected software
DENX -> U-boot 

 References:
http://lists.opensuse.org/opensuse-security-announce/2019-10/msg00002.html
http://lists.opensuse.org/opensuse-security-announce/2019-10/msg00004.html
https://gist.github.com/deephooloovoo/d91b81a1674b4750e662dfae93804d75
https://github.com/u-boot/u-boot/commits/master
https://lists.denx.de/pipermail/u-boot/2019-July/375516.html

Copyright 2020, cxsecurity.com

 

Back to Top