Vulnerability CVE-2019-14433


Published: 2019-08-09

Description:
An issue was discovered in OpenStack Nova before 17.0.12, 18.x before 18.2.2, and 19.x before 19.0.2. If an API request from an authenticated user ends in a fault condition due to an external exception, details of the underlying environment may be leaked in the response, and could include sensitive configuration or other data.

Type:

CWE-200

(Information Exposure)

CVSS2 => (AV:N/AC:L/Au:S/C:P/I:N/A:N)

CVSS Base Score
Impact Subscore
Exploitability Subscore
4/10
2.9/10
8/10
Exploit range
Attack complexity
Authentication
Remote
Low
Single time
Confidentiality impact
Integrity impact
Availability impact
Partial
None
None
Affected software
Openstack -> NOVA 

 References:
http://www.openwall.com/lists/oss-security/2019/08/06/6
https://launchpad.net/bugs/1837877
https://security.openstack.org/ossa/OSSA-2019-003.html
https://usn.ubuntu.com/4104-1/

Copyright 2020, cxsecurity.com

 

Back to Top