Vulnerability CVE-2019-14811


Published: 2019-09-03

Description:
A flaw was found in, ghostscript versions prior to 9.28, in the .pdf_hook_DSC_Creator procedure where it did not properly secure its privileged calls, enabling scripts to bypass `-dSAFER` restrictions. A specially crafted PostScript file could disable security protection and then have access to the file system, or execute arbitrary commands.

Type:

CWE-264

(Permissions, Privileges, and Access Controls)

CVSS2 => (AV:N/AC:M/Au:N/C:P/I:P/A:P)

CVSS Base Score
Impact Subscore
Exploitability Subscore
6.8/10
6.4/10
8.6/10
Exploit range
Attack complexity
Authentication
Remote
Medium
No required
Confidentiality impact
Integrity impact
Availability impact
Partial
Partial
Partial
Affected software
Artifex -> Ghostscript 

 References:
https://access.redhat.com/errata/RHSA-2019:2594
https://bugzilla.redhat.com/show_bug.cgi?id=CVE-2019-14811
https://lists.debian.org/debian-lts-announce/2019/09/msg00007.html
https://seclists.org/bugtraq/2019/Sep/15
https://www.debian.org/security/2019/dsa-4518

Copyright 2020, cxsecurity.com

 

Back to Top