Vulnerability CVE-2019-14850


Published: 2021-03-18

Description:
A denial of service vulnerability was discovered in nbdkit 1.12.7, 1.14.1 and 1.15.1. An attacker could connect to the nbdkit service and cause it to perform a large amount of work in initializing backend plugins, by simply opening a connection to the service. This vulnerability could cause resource consumption and degradation of service in nbdkit, depending on the plugins configured on the server-side.

Type:

CWE-406

(Insufficient Control of Network Message Volume (Network Amplification))

CVSS2 => (AV:N/AC:H/Au:N/C:N/I:N/A:P)

CVSS Base Score
Impact Subscore
Exploitability Subscore
2.6/10
2.9/10
4.9/10
Exploit range
Attack complexity
Authentication
Remote
High
No required
Confidentiality impact
Integrity impact
Availability impact
None
None
Partial
Affected software
Redhat -> Virtualization 
Redhat -> Enterprise linux 
Redhat -> Enterprise linux server 
Nbdkit project -> Nbdkit 

 References:
https://bugzilla.redhat.com/show_bug.cgi?id=1757258
https://www.redhat.com/archives/libguestfs/2019-September/msg00084.html

Copyright 2021, cxsecurity.com

 

Back to Top