Vulnerability CVE-2019-15138


Published: 2019-09-20

Description:
The html-pdf package 2.2.0 for Node.js has an arbitrary file read vulnerability via an HTML file that uses XMLHttpRequest to access a file:/// URL.

Type:

CWE-200

(Information Exposure)

Vendor: Html-pdf project
Product: Html-pdf 

CVSS2 => (AV:N/AC:L/Au:N/C:P/I:N/A:N)

CVSS Base Score
Impact Subscore
Exploitability Subscore
5/10
2.9/10
10/10
Exploit range
Attack complexity
Authentication
Remote
Low
No required
Confidentiality impact
Integrity impact
Availability impact
Partial
None
None

 References:
https://www.npmjs.com/advisories/1095

Copyright 2019, cxsecurity.com

 

Back to Top