Vulnerability CVE-2019-1559


Published: 2019-02-27   Modified: 2019-02-28

Description:
If an application encounters a fatal protocol error and then calls SSL_shutdown() twice (once to send a close_notify, and once to receive one) then OpenSSL can respond differently to the calling application if a 0 byte record is received with invalid padding compared to if a 0 byte record is received with an invalid MAC. If the application then behaves differently based on that in a way that is detectable to the remote peer, then this amounts to a padding oracle that could be used to decrypt data. In order for this to be exploitable "non-stitched" ciphersuites must be in use. Stitched ciphersuites are optimised implementations of certain commonly used ciphersuites. Also the application must call SSL_shutdown() twice even if a protocol error has occurred (applications should not do this but some do anyway). Fixed in OpenSSL 1.0.2r (Affected 1.0.2-1.0.2q).

Type:

CWE-200

(Information Exposure)

Vendor: Debian
Product: Debian linux 
Version: 9.0; 8.0;
Vendor: Tenable
Product: Nessus 
Version: 8.2.3;
Vendor: Opensuse
Product: LEAP 
Version: 42.3; 15.0;
Vendor: F5
Product: Traffix signaling delivery controller 
Version: 4.4.0;
Vendor: Canonical
Product: Ubuntu linux 
Version:
18.10
18.04
16.04
Vendor: Openssl
Product: Openssl 
Version:
1.0.2q
1.0.2p
1.0.2o
1.0.2n
1.0.2m
1.0.2l
1.0.2k
1.0.2j
1.0.2i
1.0.2h
1.0.2g
1.0.2f
1.0.2e
1.0.2d
1.0.2c
1.0.2b
1.0.2a
1.0.2
Vendor: Netapp
Product: Snapcenter 
Product: Steelstore cloud integrated storage 
Product: Storagegrid 
Product: Hyper converged infrastructure 
Product: Oncommand workflow automation 
Product: Santricity smi-s provider 
Product: Snapdrive 
Product: Storage automation store 
Product: Element software 
Product: Oncommand unified manager 
Product: Ontap select deploy administration utility 
Product: Ontap select deploy 

CVSS2 => (AV:N/AC:M/Au:N/C:P/I:N/A:N)

CVSS Base Score
Impact Subscore
Exploitability Subscore
4.3/10
2.9/10
8.6/10
Exploit range
Attack complexity
Authentication
Remote
Medium
No required
Confidentiality impact
Integrity impact
Availability impact
Partial
None
None

 References:
http://lists.opensuse.org/opensuse-security-announce/2019-03/msg00041.html
http://lists.opensuse.org/opensuse-security-announce/2019-04/msg00019.html
http://lists.opensuse.org/opensuse-security-announce/2019-04/msg00046.html
http://lists.opensuse.org/opensuse-security-announce/2019-04/msg00047.html
http://lists.opensuse.org/opensuse-security-announce/2019-05/msg00049.html
http://www.securityfocus.com/bid/107174
https://git.openssl.org/gitweb/?p=openssl.git;a=commitdiff;h=e9bbefbf0f24c57645e7ad6a5a71ae649d18ac8e
https://kc.mcafee.com/corporate/index?page=content&id=SB10282
https://lists.debian.org/debian-lts-announce/2019/03/msg00003.html
https://security.gentoo.org/glsa/201903-10
https://security.netapp.com/advisory/ntap-20190301-0001/
https://security.netapp.com/advisory/ntap-20190301-0002/
https://security.netapp.com/advisory/ntap-20190423-0002/
https://support.f5.com/csp/article/K18549143
https://usn.ubuntu.com/3899-1/
https://www.debian.org/security/2019/dsa-4400
https://www.openssl.org/news/secadv/20190226.txt
https://www.oracle.com/technetwork/security-advisory/cpuapr2019-5072813.html
https://www.tenable.com/security/tns-2019-02
https://www.tenable.com/security/tns-2019-03

Related CVE
CVE-2019-5507
SnapManager for Oracle prior to version 3.4.2P1 are susceptible to a vulnerability which when successfully exploited could lead to disclosure of sensitive information.
CVE-2019-5505
ONTAP Select Deploy administration utility versions 2.2 through 2.12.1 transmit credentials in plaintext.
CVE-2019-5504
ONTAP Select Deploy administration utility versions 2.12 & 2.12.1 ship with an HTTP service bound to the network allowing unauthenticated remote attackers to perform administrative actions.
CVE-2019-5503
OnCommand Workflow Automation versions prior to 5.0 shipped without certain HTTP Security headers configured which could allow an attacker to obtain sensitive information via unspecified vectors.
CVE-2019-15902
A backporting error was discovered in the Linux stable/longterm kernel 4.4.x through 4.4.190, 4.9.x through 4.9.190, 4.14.x through 4.14.141, 4.19.x through 4.19.69, and 5.2.x through 5.2.11. Misuse of the upstream "x86/ptrace: Fix possible spectre-v...
CVE-2019-5498
OnCommand Insight versions through 7.3.6 may disclose sensitive account information to an authenticated user.
CVE-2019-5502
SMB in Data ONTAP operating in 7-Mode versions prior to 8.2.5P3 has weak cryptography which when exploited could lead to information disclosure or addition or modification of data.
CVE-2019-5501
Data ONTAP operating in 7-Mode versions prior to 8.2.5P3 may disclose sensitive LDAP account information to unauthenticated remote attackers.

Copyright 2019, cxsecurity.com

 

Back to Top