Vulnerability CVE-2019-16220


Published: 2019-09-11

Description:
In WordPress before 5.2.3, validation and sanitization of a URL in wp_validate_redirect in wp-includes/pluggable.php could lead to an open redirect.

Type:

CWE-601

(URL Redirection to Untrusted Site ('Open Redirect'))

CVSS2 => (AV:N/AC:M/Au:N/C:P/I:P/A:N)

CVSS Base Score
Impact Subscore
Exploitability Subscore
5.8/10
4.9/10
8.6/10
Exploit range
Attack complexity
Authentication
Remote
Medium
No required
Confidentiality impact
Integrity impact
Availability impact
Partial
Partial
None
Affected software
Wordpress -> Wordpress 

 References:
https://core.trac.wordpress.org/changeset/45971
https://github.com/WordPress/WordPress/commit/c86ee39ff4c1a79b93c967eb88522f5c09614a28
https://wordpress.org/news/2019/09/wordpress-5-2-3-security-and-maintenance-release/
https://wpvulndb.com/vulnerabilities/9863

Copyright 2020, cxsecurity.com

 

Back to Top