Vulnerability CVE-2019-9894


Published: 2019-03-21

Description:
A remotely triggerable memory overwrite in RSA key exchange in PuTTY before 0.71 can occur before host key verification.

Type:

CWE-320

(Key Management Errors)

CVSS2 => (AV:N/AC:L/Au:N/C:N/I:P/A:P)

CVSS Base Score
Impact Subscore
Exploitability Subscore
6.4/10
4.9/10
10/10
Exploit range
Attack complexity
Authentication
Remote
Low
No required
Confidentiality impact
Integrity impact
Availability impact
None
Partial
Partial
Affected software
Putty -> Putty 
Opensuse -> LEAP 
Netapp -> Oncommand unified manager 
Fedoraproject -> Fedora 
Debian -> Debian linux 

 References:
http://lists.opensuse.org/opensuse-security-announce/2019-04/msg00004.html
http://lists.opensuse.org/opensuse-security-announce/2019-04/msg00020.html
https://lists.debian.org/debian-lts-announce/2019/04/msg00023.html
https://lists.fedoraproject.org/archives/list/package-announce@lists.fedoraproject.org/message/36LWQ3NPFIV7DC7TC4KFPRYRH2OR7SZ2/
https://lists.fedoraproject.org/archives/list/package-announce@lists.fedoraproject.org/message/LDO3F267P347E6U2IILFCYW7JPTLCCES/
https://seclists.org/bugtraq/2019/Apr/6
https://security.netapp.com/advisory/ntap-20190404-0001/
https://www.chiark.greenend.org.uk/~sgtatham/putty/changes.html
https://www.debian.org/security/2019/dsa-4423

Copyright 2022, cxsecurity.com

 

Back to Top