Vulnerability CVE-2020-12872


Published: 2020-05-15

Description:
yaws_config.erl in Yaws through 2.0.2 and/or 2.0.7 loads obsolete TLS ciphers, as demonstrated by ones that allow Sweet32 attacks.

Type:

CWE-326

(Inadequate Encryption Strength)

CVSS2 => (AV:L/AC:L/Au:N/C:P/I:N/A:N)

CVSS Base Score
Impact Subscore
Exploitability Subscore
2.1/10
2.9/10
3.9/10
Exploit range
Attack complexity
Authentication
Local
Low
No required
Confidentiality impact
Integrity impact
Availability impact
Partial
None
None
Affected software
YAWS -> YAWS 

 References:
https://github.com/erlyaws/yaws/blob/c0fd79f17d52628fcec527da7fa3e788c283c445/src/yaws_config.erl#L2068-L2075
https://github.com/erlyaws/yaws/releases
https://medium.com/@charlielabs101/cve-2020-12872-df315411aa70
https://sweet32.info/

Copyright 2022, cxsecurity.com

 

Back to Top