Vulnerability CVE-2020-13162


Published: 2020-06-16   Modified: 2020-06-17

Description:
A time-of-check time-of-use vulnerability in PulseSecureService.exe in Pulse Secure Client versions prior to 9.1.6 down to 5.3 R70 for Windows (which runs as NT AUTHORITY/SYSTEM) allows unprivileged users to run a Microsoft Installer executable with elevated privileges.

See advisories in our WLB2 database:
Topic
Author
Date
Med.
Pulse Secure Client For Windows Local Privilege Escalation
Marco Ortisi
17.06.2020

Type:

CWE-367

(Time-of-check Time-of-use (TOCTOU) Race Condition)

CVSS2 => (AV:L/AC:M/Au:N/C:C/I:C/A:C)

CVSS Base Score
Impact Subscore
Exploitability Subscore
6.9/10
10/10
3.4/10
Exploit range
Attack complexity
Authentication
Local
Medium
No required
Confidentiality impact
Integrity impact
Availability impact
Complete
Complete
Complete
Affected software
Pulsesecure -> Pulse secure desktop client 
Pulsesecure -> Pulse secure installer service 

 References:
http://packetstormsecurity.com/files/158117/Pulse-Secure-Client-For-Windows-Local-Privilege-Escalation.html
http://seclists.org/fulldisclosure/2020/Jun/25
https://kb.pulsesecure.net/?atype=sa
https://kb.pulsesecure.net/articles/Pulse_Security_Advisories/SA44503
https://twitter.com/gsepcali/status/1262551597990711296
https://twitter.com/gsepcali/status/1272927080909623297
https://twitter.com/sepcali/status/1262551597990711296
https://www.redtimmy.com/privilege-escalation/pulse-secure-client-for-windows-9-1-6-toctou-privilege-escalation-cve-2020-13162/

Copyright 2021, cxsecurity.com

 

Back to Top