Vulnerability CVE-2020-15087


Published: 2020-06-30

Description:
In Presto before version 337, authenticated users can bypass authorization checks by directly accessing internal APIs. This impacts Presto server installations with secure internal communication configured. This does not affect installations that have not configured secure internal communication, as these installations are inherently insecure. This only affects Presto server installations. This does NOT affect clients such as the CLI or JDBC driver. This vulnerability has been fixed in version 337. Additionally, this issue can be mitigated by blocking network access to internal APIs on the coordinator and workers.

Type:

CWE-285

(Improper Authorization)

 References:
https://github.com/prestosql/presto/pull/4199
https://github.com/prestosql/presto/security/advisories/GHSA-f6pc-crhh-cp96
https://prestosql.io/docs/current/release/release-337.html#security-changes

Copyright 2020, cxsecurity.com

 

Back to Top