Vulnerability CVE-2020-15253


Published: 2020-10-14

Description:
Versions of Grocy <= 2.7.1 are vulnerable to Cross-Site Scripting via the Create Shopping List module, that is rendered upon deleting that Shopping List. The issue was also found in users, batteries, chores, equipment, locations, quantity units, shopping locations, tasks, taskcategories, product groups, recipes and products. Authentication is required to exploit these issues and Grocy should not be publicly exposed. The linked reference details a proof-of-concept.

Type:

CWE-79

(Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting'))

CVSS2 => (AV:N/AC:M/Au:S/C:N/I:P/A:N)

CVSS Base Score
Impact Subscore
Exploitability Subscore
3.5/10
2.9/10
6.8/10
Exploit range
Attack complexity
Authentication
Remote
Medium
Single time
Confidentiality impact
Integrity impact
Availability impact
None
Partial
None
Affected software
Grocy -> Grocy 

 References:
https://github.com/grocy/grocy/commit/0624b0df594a4353ef25e6b1874565ea52ce7772
https://github.com/grocy/grocy/commit/0df2590de27c60c18b7db6e056347bd2aff5a887
https://github.com/grocy/grocy/issues/996
https://github.com/grocy/grocy/security/advisories/GHSA-7f37-2fjr-v9p7

Copyright 2020, cxsecurity.com

 

Back to Top