Vulnerability CVE-2020-27868


Published: 2021-02-12

Description:
This vulnerability allows remote attackers to execute arbitrary code on affected installations of Qognify Ocularis 5.9.0.395. Authentication is not required to exploit this vulnerability. The specific flaw exists within the handling of serialized objects provided to the EventCoordinator endpoint. The issue results from the lack of proper validation of user-supplied data, which can result in deserialization of untrusted data. An attacker can leverage this vulnerability to execute code in the context of SYSTEM. Was ZDI-CAN-11257.

Type:

CWE-502

(Deserialization of Untrusted Data)

CVSS2 => (AV:N/AC:L/Au:N/C:C/I:C/A:C)

CVSS Base Score
Impact Subscore
Exploitability Subscore
10/10
10/10
10/10
Exploit range
Attack complexity
Authentication
Remote
Low
No required
Confidentiality impact
Integrity impact
Availability impact
Complete
Complete
Complete
Affected software
Qognify -> Ocularis 

 References:
https://onssi.ftpstream.com/download/pbkwqEBlNQLBpfywrxvR/onssi/Software/Ocularis%206.0/Special%20Build/Ocularis%20Base.exe
https://www.zerodayinitiative.com/advisories/ZDI-20-1453/

Copyright 2021, cxsecurity.com

 

Back to Top