Vulnerability CVE-2020-5263


Published: 2020-04-09

Description:
auth0.js (NPM package auth0-js) greater than version 8.0.0 and before version 9.12.3 has a vulnerability. In the case of an (authentication) error, the error object returned by the library contains the original request of the user, which may include the plaintext password the user entered. If the error object is exposed or logged without modification, the application risks password exposure. This is fixed in version 9.12.3

Type:

CWE-522

(Insufficiently Protected Credentials)

CVSS2 => (AV:N/AC:L/Au:S/C:P/I:N/A:N)

CVSS Base Score
Impact Subscore
Exploitability Subscore
4/10
2.9/10
8/10
Exploit range
Attack complexity
Authentication
Remote
Low
Single time
Confidentiality impact
Integrity impact
Availability impact
Partial
None
None
Affected software
Auth0 -> Auth0.js 

 References:
https://github.com/auth0/auth0.js/commit/355ca749b229fb93142f0b3978399b248d710828
https://github.com/auth0/auth0.js/security/advisories/GHSA-prfq-f66g-43mp

Copyright 2021, cxsecurity.com

 

Back to Top