Vulnerability CVE-2020-7009


Published: 2020-03-31

Description:
Elasticsearch versions from 6.7.0 before 6.8.8 and 7.0.0 before 7.6.2 contain a privilege escalation flaw if an attacker is able to create API keys. An attacker who is able to generate an API key can perform a series of steps that result in an API key being generated with elevated privileges.

Type:

CWE-269

(Improper Privilege Management)

CVSS2 => (AV:N/AC:L/Au:N/C:P/I:P/A:P)

CVSS Base Score
Impact Subscore
Exploitability Subscore
7.5/10
6.4/10
10/10
Exploit range
Attack complexity
Authentication
Remote
Low
No required
Confidentiality impact
Integrity impact
Availability impact
Partial
Partial
Partial
Affected software
Elastic -> Elasticsearch 

 References:
https://discuss.elastic.co/t/elastic-stack-6-8-8-and-7-6-2-security-update/225920
https://security.netapp.com/advisory/ntap-20200403-0004/
https://www.elastic.co/community/security/

Copyright 2020, cxsecurity.com

 

Back to Top