Vulnerability CVE-2021-22963


Published: 2021-10-14

Description:
A redirect vulnerability in the fastify-static module version < 4.2.4 allows remote attackers to redirect users to arbitrary websites via a double slash // followed by a domain: http://localhost:3000//google.com/%2e%2e.The issue shows up on all the fastify-static applications that set redirect: true option. By default, it is false.

 References:
https://hackerone.com/reports/1354255

Copyright 2021, cxsecurity.com

 

Back to Top