Vulnerability CVE-2021-23327


Published: 2021-02-09

Description:
The package apexcharts before 3.24.0 are vulnerable to Cross-site Scripting (XSS) via lack of sanitization of graph legend fields.

Type:

CWE-79

(Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting'))

CVSS2 => (AV:N/AC:M/Au:N/C:N/I:P/A:N)

CVSS Base Score
Impact Subscore
Exploitability Subscore
4.3/10
2.9/10
8.6/10
Exploit range
Attack complexity
Authentication
Remote
Medium
No required
Confidentiality impact
Integrity impact
Availability impact
None
Partial
None
Affected software
Fusioncharts -> Apexcharts 

 References:
https://github.com/apexcharts/apexcharts.js/commit/68f3f34d125719b4767614fe0a595cc65bde1d19
https://github.com/apexcharts/apexcharts.js/pull/2158
https://snyk.io/vuln/SNYK-JAVA-ORGWEBJARSNPM-1070616
https://snyk.io/vuln/SNYK-JS-APEXCHARTS-1062708

Copyright 2022, cxsecurity.com

 

Back to Top