Vulnerability CVE-2021-23429


Published: 2021-08-24

Description:
All versions of package transpile are vulnerable to Denial of Service (DoS) due to a lack of input sanitization or whitelisting, coupled with improper exception handling in the .to() function.

Type:

CWE-755

CVSS2 => (AV:N/AC:L/Au:N/C:N/I:N/A:P)

CVSS Base Score
Impact Subscore
Exploitability Subscore
5/10
2.9/10
10/10
Exploit range
Attack complexity
Authentication
Remote
Low
No required
Confidentiality impact
Integrity impact
Availability impact
None
None
Partial
Affected software
Transpile project -> Transpile 

 References:
https://github.com/stealjs/transpile/blob/56aaeb26f69496e45a60c03dc92653d53021d4ac/main.js%23L53
https://snyk.io/vuln/SNYK-JS-TRANSPILE-1290774

Copyright 2021, cxsecurity.com

 

Back to Top