Vulnerability CVE-2021-32028


Published: 2021-10-11

Description:
A flaw was found in postgresql. Using an INSERT ... ON CONFLICT ... DO UPDATE command on a purpose-crafted table, an authenticated database user could read arbitrary bytes of server memory. The highest threat from this vulnerability is to data confidentiality.

Type:

CWE-200

(Information Exposure)

CVSS2 => (AV:N/AC:L/Au:S/C:P/I:N/A:N)

CVSS Base Score
Impact Subscore
Exploitability Subscore
4/10
2.9/10
8/10
Exploit range
Attack complexity
Authentication
Remote
Low
Single time
Confidentiality impact
Integrity impact
Availability impact
Partial
None
None
Affected software
Postgresql -> Postgresql 

 References:
https://bugzilla.redhat.com/show_bug.cgi?id=1956877
https://www.postgresql.org/support/security/CVE-2021-32028

Copyright 2021, cxsecurity.com

 

Back to Top