Vulnerability CVE-2022-1118


Published: 2022-05-17   Modified: 2022-05-18

Description:
Connected Components Workbench (v13.00.00 and prior), ISaGRAF Workbench (v6.0 though v6.6.9), and Safety Instrumented System Workstation (v1.2 and prior (for Trusted Controllers)) do not limit the objects that can be deserialized. This allows attackers to craft a malicious serialized object that, if opened by a local user in Connected Components Workbench, may result in arbitrary code execution. This vulnerability requires user interaction to be successfully exploited

Type:

CWE-502

(Deserialization of Untrusted Data)

 References:
https://www.cisa.gov/uscert/ics/advisories/icsa-22-095-01

Copyright 2022, cxsecurity.com

 

Back to Top