Vulnerability CVE-2022-1985


Published: 2022-06-13

Description:
The Download Manager Plugin for WordPress is vulnerable to reflected Cross-Site Scripting in versions up to, and including 3.2.42. This is due to insufficient input sanitization and output escaping on the 'frameid' parameter found in the ~/src/Package/views/shortcode-iframe.php file.

See advisories in our WLB2 database:
Topic
Author
Date
Low
WordPress Download Manager 3.2.42 Cross Site Scripting
Rafie Muhammad
11.06.2022

Type:

CWE-79

(Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting'))

 References:
https://plugins.trac.wordpress.org/changeset?sfp_email=&sfph_mail=&reponame=&old=2736071%40download-manager&new=2736071%40download-manager&sfp_email=&sfph_mail
=
https://www.wordfence.com/blog/2022/06/security-vulnerability-download-manager-plugin/
https://www.wordfence.com/vulnerability-advisories/#CVE-2022-1985

Copyright 2022, cxsecurity.com

 

Back to Top