Vulnerability CVE-2022-24831


Published: 2022-05-14

Description:
OpenClinica is an open source software for Electronic Data Capture (EDC) and Clinical Data Management (CDM). Versions prior to 3.16.1 are vulnerable to SQL injection due to the use of string concatenation to create SQL queries instead of prepared statements. No known workarounds exist. This issue has been patched in 3.16.1, 3.15.9, 3.14.1, and 3.13.1 and users are advised to upgrade.

 References:
https://github.com/OpenClinica/OpenClinica/security/advisories/GHSA-5289-4jwp-xp9h
https://github.com/OpenClinica/OpenClinica/pull/3490/commits/b152cc63019230c9973965a98e4386ea5322c18f

Copyright 2022, cxsecurity.com

 

Back to Top