Vulnerability CVE-2022-24893


Published: 2022-06-25

Description:
ESP-IDF is the official development framework for Espressif SoCs. In Espressif??s Bluetooth Mesh SDK (`ESP-BLE-MESH`), a memory corruption vulnerability can be triggered during provisioning, because there is no check for the `SegN` field of the Transaction Start PDU. This can result in memory corruption related attacks and potentially attacker gaining control of the entire system. Patch commits are available on the 4.1, 4.2, 4.3 and 4.4 branches and users are recommended to upgrade. The upgrade is applicable for all applications and users of `ESP-BLE-MESH` component from `ESP-IDF`. As it is implemented in the Bluetooth Mesh stack, there is no workaround for the user to fix the application layer without upgrading the underlying firmware.

Type:

CWE-787

 References:
https://github.com/espressif/esp-idf/security/advisories/GHSA-7f7f-jj2q-28wm

Copyright 2022, cxsecurity.com

 

Back to Top