Vulnerability CVE-2022-29256


Published: 2022-05-25   Modified: 2022-05-26

Description:
sharp is an application for Node.js image processing. Prior to version 0.30.5, there is a possible vulnerability in logic that is run only at `npm install` time when installing versions of `sharp` prior to the latest v0.30.5. If an attacker has the ability to set the value of the `PKG_CONFIG_PATH` environment variable in a build environment then they might be able to use this to inject an arbitrary command at `npm install` time. This is not part of any runtime code, does not affect Windows users at all, and is unlikely to affect anyone that already cares about the security of their build environment. This problem is fixed in version 0.30.5.

 References:
https://github.com/lovell/sharp/security/advisories/GHSA-gp95-ppv5-3jc5
https://github.com/lovell/sharp/commit/a6aeef612be50f5868a77481848b1de674216f0c

Copyright 2022, cxsecurity.com

 

Back to Top