Vulnerability CVE-2022-2943


Published: 2022-09-06

Description:
The WordPress Infinite Scroll ?? Ajax Load More plugin for Wordpress is vulnerable to arbitrary file reading in versions up to, and including, 5.5.3 due to insufficient file path validation on the alm_repeaters_export() function. This makes it possible for authenticated attackers, with administrative privileges, to download arbitrary files hosted on the server that may contain sensitive content, such as the wp-config.php file.

Type:

CWE-73

(External Control of File Name or Path)

 References:
https://plugins.svn.wordpress.org/ajax-load-more/tags/5.5.4/README.txt
https://gist.github.com/Xib3rR4dAr/f9a4b4838154854ec6cde7d5deb76bf9
https://www.wordfence.com/vulnerability-advisories/#CVE-2022-2943

Copyright 2023, cxsecurity.com

 

Back to Top