Vulnerability CVE-2022-36338


Published: 2022-09-23

Description:
An issue was discovered in Insyde InsydeH2O with kernel 5.0 through 5.5. An SMM callout vulnerability in the SMM driver FwBlockServiceSmm, creating SMM, leads to arbitrary code execution. An attacker can replace the pointer to the UEFI boot service GetVariable with a pointer to malware, and then generate a software SMI.

 References:
https://www.insyde.com/security-pledge
https://www.insyde.com/security-pledge/SA-2022029
https://binarly.io/advisories/BRLY-2022-017/index.html

Copyright 2022, cxsecurity.com

 

Back to Top