Vulnerability CVE-2022-41231


Published: 2022-09-21

Description:
Jenkins Build-Publisher Plugin 1.22 and earlier allows attackers with Item/Configure permission to create or replace any config.xml file on the Jenkins controller file system by providing a crafted file name to an API endpoint.

Type:

CWE-22

(Improper Limitation of a Pathname to a Restricted Directory ('Path Traversal'))

 References:
https://www.jenkins.io/security/advisory/2022-09-21/#SECURITY-2139

Copyright 2022, cxsecurity.com

 

Back to Top