Vulnerability CVE-2022-41322


Published: 2022-09-23

Description:
In Kitty before 0.26.2, insufficient validation in the desktop notification escape sequence can lead to arbitrary code execution. The user must display attacker-controlled content in the terminal, then click on a notification popup.

 References:
https://github.com/kovidgoyal/kitty/compare/v0.26.1...v0.26.2
https://github.com/kovidgoyal/kitty/commit/f05783e64d5fa62e1aed603e8d69aced5e49824f
https://sw.kovidgoyal.net/kitty/changelog/#detailed-list-of-changes
https://bugs.gentoo.org/868543

Copyright 2022, cxsecurity.com

 

Back to Top