Vulnerability CVE-2022-46159


Published: 2022-12-02

Description:
Discourse is an open-source discussion platform. In version 2.8.13 and prior on the `stable` branch and version 2.9.0.beta14 and prior on the `beta` and `tests-passed` branches, any authenticated user can create an unlisted topic. These topics, which are not readily available to other users, can take up unnecessary site resources. A patch for this issue is available in the `main` branch of Discourse. There are no known workarounds available.

Type:

CWE-770

 References:
https://github.com/discourse/discourse/security/advisories/GHSA-qf99-xpx6-hgxp
https://github.com/discourse/discourse/commit/0ce38bd7bce862db251b882613ab7053ca777382

Copyright 2023, cxsecurity.com

 

Back to Top