Vulnerability CVE-2024-21525


Published: 2024-07-10

Description:
All versions of the package node-twain are vulnerable to Improper Check or Handling of Exceptional Conditions due to the length of the source data not being checked. Creating a new twain.TwainSDK with a productName or productFamily, manufacturer, version.info property of length >= 34 chars leads to a buffer overflow vulnerability.

 References:
https://security.snyk.io/vuln/SNYK-JS-NODETWAIN-6421153
https://gist.github.com/dellalibera/55b87634a6c360e5be22a715f0566c99

Copyright 2024, cxsecurity.com

 

Back to Top