Vulnerability CVE-2024-37310


Published: 2024-07-10

Description:
EVerest is an EV charging software stack. An integer overflow in the "v2g_incoming_v2gtp" function in the v2g_server.cpp implementation can allow a remote attacker to overflow the process' heap. This vulnerability is fixed in 2024.3.1 and 2024.6.0.

 References:
https://github.com/EVerest/everest-core/security/advisories/GHSA-8g9q-7qr9-vc96
https://github.com/EVerest/everest-core/commit/f73620c4c0f626e1097068a47e10cc27b369ad8e
https://github.com/EVerest/everest-core/releases/tag/2024.3.1
https://github.com/EVerest/everest-core/releases/tag/2024.6.0

Copyright 2024, cxsecurity.com

 

Back to Top