Apple QuickDraw/QuickTime Multiple Vulnerabilities

2006.05.15
Risk: High
Local: Yes
Remote: Yes
CWE: N/A

____________________________________________________________________ McAfee, Inc. McAfee Avert? Labs Security Advisory Public Release Date: 2006-05-11 Apple QuickDraw/QuickTime Multiple Vulnerabilities CVE-2006-1249, CVE-2006-1453, CVE-2006-1454, CVE-2006-1459, CVE-2006-1460, CVE-2006-1461, CVE-2006-1462, CVE-2006-1464, CVE-2006-1465 ______________________________________________________________________ * Synopsis Apple QuickTime and Apple QuickDraw are multimedia technologies used to process image, audio and video data. QuickTime and QuickDraw are used by the Mac OS X operating system and by the QuickTime media player for Microsoft Windows. Two code execution vulnerabilities are present in QuickDraw PICT image format support. Twenty one code execution vulnerabilities are present in QuickTime support for various multimedia formats including: MOV, H.264, MPEG 4, AVI, FPX and SWF. Exploitation could lead to execution of arbitrary code. In order for an attack to succeed user interaction is required and therefore the risk factor for these issues is medium. ______________________________________________________________________ * Vulnerable Systems Mac OS X 10.4.6 and below without May 2006 security update installed QuickTime 7.0.4 and below for Mac OS X QuickTime for Windows 7.0.4 and below ______________________________________________________________________ * Vulnerability Information CVE-2006-1249 Two integer overflow vulnerabilities are present in QuickTime FlashPix (FPX) image format support. CVE-2006-1453, CVE-2006-1454 Two buffer overflow vulnerabilities are present in QuickDraw PICT image format support. CVE-2006-1459 Seven integer overflow vulnerabilities are present in QuickTime MOV video format support. CVE-2006-1460 Five buffer overflow vulnerabilities are present in QuickTime MOV video format support. CVE-2006-1461 Two buffer overflow vulnerabilities are present in QuickTime Flash (SWF) support. CVE-2006-1462 Three integer overflow vulnerabilities are presenting QuickTime H.264 (M4V) video format support. CVE-2006-1464 One buffer overflow vulnerability is present in QuickTime MPEG4 (M4P) video format support. CVE-2006-1465 One buffer overflow vulnerability is present in QuickTime AVI video format support. ______________________________________________________________________ * Resolution Apple has included fixes for the QuickDraw issues in the May 2006 Mac OS X security update and in QuickTime version 7.1 for Windows. Apple has included fixes for the QuickTime issues in QuickTime version 7.1 for Mac OS X and for Windows. ______________________________________________________________________ * Credits These vulnerabilities were discovered by Mike Price of McAfee Avert Labs. ______________________________________________________________________ * Legal Notice Copyright (C) 2006 McAfee, Inc. The information contained within this advisory is provided for the convenience of McAfee?s customers, and may be redistributed provided that no fee is charged for distribution and that the advisory is not modified in any way. McAfee makes no representations or warranties regarding the accuracy of the information referenced in this document, or the suitability of that information for your purposes. McAfee, Inc. and McAfee Avert Labs are registered Trademarks of McAfee, Inc. and/or its affiliated companies in the United States and/or other Countries. All other registered and unregistered trademarks in this document are the sole property of their respective owners. ______________________________________________________________________


Vote for this issue:
50%
50%


 

Thanks for you vote!


 

Thanks for you comment!
Your message is in quarantine 48 hours.

Comment it here.


(*) - required fields.  
{{ x.nick }} | Date: {{ x.ux * 1000 | date:'yyyy-MM-dd' }} {{ x.ux * 1000 | date:'HH:mm' }} CET+1
{{ x.comment }}

Copyright 2017, cxsecurity.com

 

Back to Top